1. renatkh's Avatar
    Hi all,
    I have been trying to jailbreak my old iphone 2G w/ FW 3.1.3 for a while now. I tried redsn0w 9.4 didn't work. It simply passes the download jailbreak data part and says "Done!" while iphone displays black screen instead of showing the hdd. I have tried custom ipsw with iReb, but iReb did nothing. It did not crash and did not turn iphone's screen white.

    The only thing that successfully jailbroke my phone was jailbreakme.com I got cydia and installed openSSH. However, I can't install ultrasn0w to unlock my phone. if I do it through cydia it gives an error during installation and after reboot cydia reports that the package was broken and needs to be removed. I assumed that it is due to my phone being so old. Maybe this version of ultrasn0w doesn't support iphone 2G any more. So I decided to install ultrasn0w 0.9.3 manually. I have created folder on the iphone /var/root/Media/Cydia/AutoInstall/ and dropped *.deb files there through ssh, then rebooted twice. However, nothing changed. I think it didn't install anything, because the phone wasn't broken with redsn0w. In addition now the phone turns off every time it spends 2 minutes in sleep mode.

    One more thing, I am using an ipod's cable. The itunes work fine with it. it can be updated etc, so I assumed the cable is fine.

    I am out of options, and have no idea what to do next. People report that everything is so easy, but doesn't work in my case. I hate to throw away this phone, think it is still useful piece.
    Any help will be highly appreciated.
    Last edited by renatkh; 2012-08-06 at 07:25 AM.
    2012-08-06 07:23 AM
  2. H4CK3R's Avatar
    Dang, old firmware lol. Lots of things aren't compatible with the 2G, which is an issue that causes most people to want to throw their phone's out the window. I would try using Sn0wbreeze BTW. It's a very clean and smooth jailbreak and it does 3.1.3. So I think it's worht a shot. I never really liked JailbreakMe much either since it was kinda missing some things.
    2012-08-06 11:26 PM
  3. renatkh's Avatar
    Some new information,
    It looks like the procedure for ultrasn0w installation worked, because cydia was saying there is an update available for my software, which was ultrasn0w. However, during update there where same errors as before, and my phone doesn't boot any more as expected. So restoring and starting over. But the real question is why ultrasn0w 0.9.3 didn't unlock my phone?! It was installed, so what is wrong? Any ideas?
    Last edited by renatkh; 2012-08-07 at 12:03 AM.
    2012-08-06 11:46 PM
  4. H4CK3R's Avatar
    I don't know either bud. Maybe there was already an AutoInstall folder? There's lots of things that can cause it. But it's good that you're starting fresh. Something probably went terribly wrong during the install, there's no way to know unless you know the error code(s).
    2012-08-07 12:30 AM
  5. renatkh's Avatar
    Next thought to install droid or ubuntu! Because many apps don't work with old ios 4. However, to install it I need to jailbreak with redsn0w, PwnageTool or blackra1n. I haven't tried PwnageTool tool yet, because I'm on PC. Other did not work so far. Has anyone done iphone 2G jailbreaking recently? or everybody who would already done it a long time ago? I know iphones 2G are still sold on ebay, they do it somehow!
    2012-08-07 08:37 AM
  6. renatkh's Avatar
    Has anyone encountered a problem with redsn0w when it says Done! while my phone is in a black screen state (instead of downloading jailbreak data and hdd icon), no pineapple after all. I thought the problem is due to incompatibility with iphone 2g, but now I face exactly the same issue with iphone 3G. Any word of advise?
    2012-08-12 10:27 AM
  7. iYeow's Avatar
    You cannot use ultrasn0w on a 2g iphone. After the jailbreak you install boot loader from cydia or when you are jailbreaking it with redsn0w 0.9.4 select option Bl 3.9 & 4.6 . You must download the respective BL onto your pc.

    Do a restore to 3.1.3 , run reds now in xp2 compatibility mode and do your Jailbreak and unlock in one process.

    Here is the guide

    Last edited by iYeow; 2012-08-12 at 10:54 AM.
    2012-08-12 10:35 AM
  8. renatkh's Avatar
    I tried redsn0w 0.9.4 and it had the same problem: no pineapple or hdd ("downloading jailbreak data), only black screen, so it doesn't help. Also saw posts about keeping the home button pressed longer, did not help. Anyway, I kept searching around and found the solution. Apparently, redsn0w is not working properly under 64bit systems (sometimes). So the solution is to boot windows in "safe mode with network" and do it from there. Everything worked properly. Thanks everyone for participation. The thread may be marked as solved.
    2012-08-14 02:31 AM
  9. iYeow's Avatar
    Glad you got it sorted out
    2012-08-14 06:00 AM
  10. daleygg99's Avatar
    go check out attiphoneunlocking if you are looking for any ATT unlocks, i tried that site, its pretty good
    2014-03-04 05:46 PM