1. iSP1N3R's Avatar
    Device: iphone 4 GSM
    ios: 5.1.1 (9B206) custom firmware
    Jailbreak: Redsn0w 0.9.14b2
    Unlock: Ultrsn0w

    Hi I just updated my iphone 4 to ios 5.1.1 using custom firmware and unlocking with ultrasn0w. first I tried updating to 5.1.1 (9B208) but kept getting errors 14 & 1602, so I tried ios 5.1.1 (9B206) and was able to restore jailbreak and unlock.

    Since upgrading I have not been able to send imessages or make facetime calls, when I try activating it just hangs and doesnt activate.
    I have tried reseting my network as mentioned in another thread but it didnt help, I have also restored about 3x's and that hasnt helped either.

    Does someone know why I cant activate imessage & facetime, I really need help please.

    I dont know if this helps but sometimes I have to turn airport mode on and off for my iphone to recognise my phone number in phone setting. and I am able to download from the appstore, so my apple id is OK.

    I have also tried just preserving baseband with sn0wbreeze on ios 5.1.1 (9B208) and then jailbreaking with redsn0w 0.9.14b2 and this time it said that facetime activated, but imessage wont turn on no more, and even though it says facetime is activated I still cant facetime, the call fails when I try...

    Thanks in advance.
    2012-08-13 03:43 AM
  2. iYeow's Avatar
    Under FaceTime setting, have you logged into your apple ID ?
    For iMessage, you can try adding an email to receive iMessage and see if it works.
    2012-08-13 04:51 AM
  3. Germanese's Avatar
    Other thing to try is using SAM to get a WildCard for the Ticket.
    It is a hit an miss on that.

    But normally if you have international TXT u should be able to get it to verified for both.
    iPhone 4 Unlocked on T-Mobile | Motorola Verizon Razr M on T-Mobile | iPhone 5 Confused
    2012-08-13 04:56 AM
  4. iSP1N3R's Avatar
    Hi guys thanks for the reply.

    I have my apple id signed in to both imessage and facetime, but when ever i try send a imessage it fails and if i try facetime it also fails.. when I check the setting I notice that imessage and facetime wont activate..

    I did try follow a guide on youtube about using SAm & ipush notifications, but when I installed sam, sam was already activated and didnt have the options that were in the video.. and for some reason I couldnt deactivate it and try set it up again, it just stayed at activated and SAm loaded OK..

    is this normal for custom ios 5.1.1 to have trouble with imessage and facetime.. when I was on custom ios 5.0.1 I had no trouble what so ever, and I am all out of ideas.. I have trouble shooted everything could think of, but all with no luck ofc..

    i even tried just setting up imessage before I installed ultrasn0w, and this time it activates, but again when I try send a message it returns an error ""Not Delivered""
    Last edited by iSP1N3R; 2012-08-13 at 05:52 AM.
    2012-08-13 05:48 AM
  5. iYeow's Avatar
    Did you create your own custom fw ? Create another one and restore again, make sure you setup iphone as new .
    2012-08-13 07:23 AM
  6. iSP1N3R's Avatar
    Hi iyeow thanks for the help, H4CK3R told me you would be the best to speak to about this.
    I have created a few custom firmwares, with both iOS 5.1.1 (9B206) and (9B208). When creating custom ios 5.1.1 (9B208) with redsn0w it wouldn't let me restore. I kept getting errors 14 & 1602. But had no trouble restoring to custom iOS 5.1.1 (9B206)

    I tried creating them with sn0wbreeze, which didn't help & I even tried just creating the firmware with sn0wbreeze were you just preserve the baseband and then used redsn0w to jailbreak it.

    But just preserving the baseband with sn0wbreeze was worse because it wouldn't let me turn iMessages on.

    Lol I have literally ran out of ideas to trouble shoot an was looking at buying a 4s outright, but hopefully I won't have to resort to that. If I can't fix it the only other option I have is to try downgrade back to ios 5.0.1 which I hope I won't have to either.
    2012-08-13 10:05 AM
  7. iSP1N3R's Avatar
    ill try it on my daughters notebook, and reply back..

    just have another question, i have a sam ticket backed up for my other iphone, and now you can use redsn0w to restore the ticket during jailbreak.. what I need to know is when I update to ios 5.1.1 do I need a custom install for that too or just upgrade to normal ios 5.1.1 and then use redsn0w to jailbreak and restore SAm ticket.


    iyeow why would u delete the last post you wrote, i dont get it...
    Last edited by iSP1N3R; 2012-08-15 at 08:38 AM. Reason: iyeow deleted his post which was made after my 6th post???
    2012-08-13 02:46 PM
  8. iSP1N3R's Avatar
    I tried restoring on a new pc, i tried both redsn0w and sn0wbreeze and still the same i cant send imessages or facetime... after i unllock with ultrasn0w is there any tweak or activation I am supposed to do... baically I am doing the following atm...

    1: I create custom firmware,
    2: I enter pwnDFU
    3: I use itunes to restore
    4: I run cydia and update
    5: I restart iphone
    6: I open cydia and install ultrasn0w
    7: I restart iphone
    8: I setup iphone.. (tried both, setup iphone from itunes or setup iphone from iphone)
    9: I check to make sure imessage is activated

    is there anything else I should do that I may not know about

    if I create custom ios with sn0w just preserving baseband, my imessage just says waiting on activation.
    if I create custom ios with sn0w inc hacktivation and cydia then restore with itunes again I cant send imessage
    if I create custom ios with redsnow I get activated imessage, but it wont send.

    1 more thing to add, not sure if it helps but everytime i jailbreak & unlock i find that the iphone doesnt know my phone number. even when i restart my iphone it doesnt recognize my number until I turn airplane mode on/off then my iphone knows my number.. but either way imessage wont work...

    also I think I just noticed something, when i try activate imessage I get a sms from my carrier saying insufficiant credit.. Im using prepaid and I have never needed credit for imessage, not sure whats going on there..

    one more thing, if i create custom ios with sn0wbreeze and then use absinthe to jailbreak and then install ultrasn0w will ruin my baseband or is it safe to jailbreak a custom firmware with absinthe...

    2012-08-16 05:15 AM
  9. iYeow's Avatar
    Did you setup your iphone as new after restoring to custom firmware ?
    You should be using an official sim for Activation.
    You must have sufficient credit for Imessage activation, you do get charged for it.
    You can try adding an email to Imessage setting for receiving, an email will be sent to you for verification. Try send an Imessage to this email.
    Do not jailbreak with Absinthe once you have restored to custom firmware of Snowbreeze as you are already jailbroken.
    However, you can jailbreak with Absinthe if you restored to N0_BB ipsw cfw created by Redsno0w .
    2012-08-16 07:31 PM
  10. iSP1N3R's Avatar
    hi I couldnt jailbreak with absinthe after creating N0_BB ipsw cfw with redsn0w because it says I need to be activated first.. so I just went ahead and jailbreaked with redsn0w and then unlocked with ultrasn0w..
    I dont have the original sim so I cant activate it that way, I the guy I bought it off isnt around no more, I bought the phone about 2yrs ago..
    but even when I created cfw with sn0wbreeze and used hacktivation, it still the same and wont let me activate or send imessages/facetime.

    I am connected to home wifi so not sure why it needs credit to activate, but I tried with a sim card that has credit and even though it did activate, it still wouldnt send imessages or facetime..

    Also I called my carrier tech support and they said if I am connected to wifi I dont need credit for imessage..

    anyways I think if I find the original carrier I can buy a sim from them just to get the iphone activated, how can I find the original carrier without going to one of them sites and entering my imei, because now I am worrie dthat maybe this iphone isnt legit, and afraid if I enter my imie it might get blocked...

    never ever am I gonna buy a 2nd hand phone again, its not worth all this damn trouble...
    2012-08-17 05:19 AM
  11. iYeow's Avatar
    You can check it from here :iPhone Carrier List – Model Numbers | `
    2012-08-17 07:25 AM
  12. iSP1N3R's Avatar
    my model number is MC603X and the run of bad luck I have been having continues, because the model number isnt listed on that site

    strange I just checked on this site http://shibabz03.blogspot.com.au/201...rier-list.html
    and it says my iphone should be factory unlocked but it aint...

    but on the site I just mentioned, it only says autralia, it doesnt tell me the carrier its tied with..

    also on that site the model number is MC603X/A mine is without the /A
    Last edited by iSP1N3R; 2012-08-18 at 02:56 AM.
    2012-08-18 02:47 AM