1. baespey's Avatar
    I've been trying to unlock my 3GS on T-Mobile for awhile now. It's on 5.1.1 with a baseband of 06.15.00, which is in fact unlockable with Ultrasn0w. I got past the iOS 5 activation by using Redsn0w and selecting 5.1 firmware (a trick I saw on Youtube). I installed Ultrasn0w and it didn't work, then I installed Ultrasn0w Fixer for 5.1.1, but it still didn't work. Every time I put the SIM in, it says "Searching" for 15 minutes then says "No Sim."

    What am I doing wrong? Do I need Ultrasn0w Fixer for 5.1 since I selected that firmware, (even though it's on 5.1.1)? My next step was to restore, then try jailbreaking with Absinthe 2.0.4. But I can't get past the activation screen.

    I tried the trick where you dial an emergency number and hold down the power button, but the moment I dial the emergency number, it immediately fails. I don't have time to hold down the power button. Any ideas?

    Here is what my device is running:

    iPhone 3GS 5.1.1 (9B206) - Apple's factory firmware
    Baseband: 06.15.00
    Serial: 88017...
    2012-08-14 05:07 PM
  2. EVO's Avatar
    have you tried to use redsn0w v0.9.14b2 to downgrade the ipad baseband to 05.13.04, a more stable unlockable baseband?

    Thread Moved
    2012-08-15 04:20 AM
  3. baespey's Avatar
    I had heard about that, but didn't do it because Snowbreeze goes up to 06.15.00. Should I give that a try? And you did mean the iPad baseband?
    2012-08-15 05:40 PM
  4. EVO's Avatar
    I'm not following you...

    Here's basically what's going on:

    Right now you are currently on the iPad baseband, which is 06.15.00, and although that baseband is unlockable, it is an unstable baseband because there are some issues that has to do with the functionality of certain features of the iPhone

    What I recommend you do is downgrade from the iPad baseband (06.15.00) to a stable baseband (05.13.04), and you "should" get your t-mobile signal back
    2012-08-15 06:23 PM