1. killerbake's Avatar
    Okay so every other forum/thread I have come across seems to only have a fix for T-Mobiles MMS. My sister recently gave me her Sprint 4s and with me having AT&T I had to order the Gevey Ultra S so I could get it working on the network.

    Like many others I was faced with the no MMS. After trying over and over again I have finally and successfully got my sprint iphone 4s to send messages over the at&t network. I have only tested this on my device, but after many failed attempts this seems to work and continue to work (even after a restart).

    Step 1. After you have successfully jailbroken and unlocked your device using the Gevey Ultra S, download Tether Me. (tether me is a commerical app on cydia that is $4.99, i have found no other way besides using this app to keep apn settings)

    Step 2. After installing Tether Me you will have to reload springboard and the iphone will lose service. Just let it be and the Ultra S will give you the "Your phone has been successfully activated" Just hit accept until you receive service once again.

    Step 3. Add these APN exactly as follows in the Tether Me settings:

    Cellular Data
    APN: phone
    Username: [leave blank]
    Password: [leave blank]

    MMS
    APN: wap.cingular
    Username: [leave blank]
    Password: [leave blank]
    MMSC: http://mmsc.cingular.com
    MMS Proxy: wireless.cingular.com
    MMS Max Message Size: [leave blank]
    MMS UA Prof URL: [leave blank]

    Step 4. After you enter in those settings go ahead and try to send a picture over txt and you should have no errors.

    Been working for me for the past two days.

    Hope this helps someone!!!!
    2012-08-24 07:56 PM
  2. jbryson's Avatar
    i unlocked my sprint iphone 4s with the gevey ultra s cdma today. for data fix i used unlockit.co.nz (free) to create a custom apn(att hspa+). after unlocking with gevey i was able to edit my apn and just filled in the mms settings you have listed here and it worked perfect. so i did not have to purchase tetherme. thank you for posting this info though because i couldnt find the right mms settings anywhere. hope this helps somebody!
    2012-08-25 04:17 AM
  3. Bo Troxell's Avatar
    According to T-Mobiles web site, the settings should be;
    1. MMS APN - epc.tmobile.com

    2. MMS MMSC - http://mms.msg.eng.t-mobile.com/mms/wapenc

    3. MMS Proxy - 216.155.165.50:8080

    4. MMS Max Message Size - 1048576

    5. MMS UA Prof URL - http://www.apple.com/mms/uaprof.rdf

    This will allow you to receive 3G/4G when T-mo finishes the refarming of their network to 1900 spectrum allowing iPhones to use the higher 3G/4G speeds by the end of the year. Some cities already have it.
    2012-08-25 05:16 AM
  4. jbryson's Avatar
    According to T-Mobiles web site, the settings should be;
    1. MMS APN - epc.tmobile.com

    2. MMS MMSC - http://mms.msg.eng.t-mobile.com/mms/wapenc

    3. MMS Proxy - 216.155.165.50:8080

    4. MMS Max Message Size - 1048576

    5. MMS UA Prof URL - http://www.apple.com/mms/uaprof.rdf

    This will allow you to receive 3G/4G when T-mo finishes the refarming of their network to 1900 spectrum allowing iPhones to use the higher 3G/4G speeds by the end of the year. Some cities already have it.
    no disrespect but i believe his purpose for this thread was because he like myself couldnt find the mms settings for the cdma iphone 4s that have been unlocked to att. not trying to be rude. jw to clarify because i dont want people who might come across this thread looking for the same fix that we were getting confused.
    2012-08-25 05:37 AM
  5. jbryson's Avatar
    any ideas on what the att internet tethering settings are? Apn-username-password. or should i not fill those in and use a third party app or mod for tethering?
    2012-08-25 09:36 PM
  6. andyle93's Avatar
    Hey man, thanks a lot it works but with a little problem. I also, have a sprint iPhone 4s 5.1.1 unlocked with a gevey ultra s running on ATT. MMS works fine, but only on during text and it won't let me use my cellular data. Like iMessage or any apps that require won't work unless I'm connected to wifi. It says I have 3G on the status but if I try to go into a browser it'll say that I'm not subscribed to a data plan..

    Any idea why?! Thank you!
    2012-10-11 07:03 AM
  7. jbryson's Avatar
    The "3G" symbol is just for aesthetics. It isn't an actual accurate reading of your settings. How do you have your apn settings set up?
    2012-10-11 11:10 PM
  8. andyle93's Avatar
    Well for the longest time I couldn't use iMessage so I downloaded tetherme and changed some +44 number to the correct number and iMessaging works now. But my apn doesn't say anything. It's all blank
    2012-10-12 09:18 PM
  9. jbryson's Avatar
    Yes that is how I fixed iMessage and factime. You need to set your apns to read the same as the op stated. Data-phone, mms-wap.cingular etc.
    2012-10-13 01:14 AM
  10. andyle93's Avatar
    Yes that is how I fixed iMessage and factime. You need to set your apns to read the same as the op stated. Data-phone, mms-wap.cingular etc.
    They never said anything about it.. So you have a sprint iPhone 4s firmware 5.1.1 gevey ultra s unlocked to run at&t and you are using the apns stated in this thread and everything is fully functional? Even iMessage and data?
    2012-10-13 01:55 AM
  11. jbryson's Avatar
    Ok andyle93. Read the first post. It states the settings you need to apply to your apn settings that will get your data and pic mms to work. For iMessage/FaceTime you use ifile or something like it to go into your carrier plist files and change the +44 number to a us number. I can't remember what it is but if you search you will gind it. Of you do as I said everything will work except for visual voicemail. I never could find a way to get that to work.
    2012-10-13 03:59 AM
  12. andyle93's Avatar
    Ok andyle93. Read the first post. It states the settings you need to apply to your apn settings that will get your data and pic mms to work. For iMessage/FaceTime you use ifile or something like it to go into your carrier plist files and change the +44 number to a us number. I can't remember what it is but if you search you will gind it. Of you do as I said everything will work except for visual voicemail. I never could find a way to get that to work.
    That's what I did! And you're right everything does work besides visual voicemai but when I use the apn settings that you provided me I can't use mms during a text.. But works fine during iMessage
    2012-10-14 10:37 AM
  13. jbryson's Avatar
    That's odd! Are you sure you have those exact mms settings? Also when you changed the number in your carrier plist did you change anything else?
    2012-10-14 04:13 PM
  14. andyle93's Avatar
    Yes I have the exact mms settings. For the last post I met to say when I don't have the apn settings on I can still send MMSs but only in iMessage not regular texts. But I put the apn settings on MMS for texts works and everything else messes up.. When you don't have the apn settings on on your phone, does mms still work in iMessage? And no I didn't change anything else. Only what was instructed to do
    2012-10-14 07:26 PM
  15. jbryson's Avatar
    iMessage will work as long as you have the data apn settings and/or wifi turned on because iMessage works over data. The mms settings are for picture messaging without iMessage. Text and calls require no specail settings to work.
    2012-10-15 01:07 AM
LINK TO POST COPIED TO CLIPBOARD