1. GuiltyCookie's Avatar
    I've tried the SAM method and also the ultrasn0w method and none of them worked

    My contract just finished so im receiving "No service" at the moment from my original O2 sim.

    I just bought a T-mobile sim card and by using the above methods i had no successful results.



    Baseband is 4.12.01
    iOS is 5.1.1
    Iphone 4



    P.S phone iss jailbroken, has been since 4.3.2 or even earlier, had restored sometimes and jailbroken it again
    2012-11-09 01:45 PM
  2. chillaxbro's Avatar
    I recently had the same problem. Not sure what SAM is but I used redsn0w to deactivate and it worked. Make sure if you have any other types of unlock on your phone to remove it first.
    2012-11-09 09:09 PM
  3. GuiltyCookie's Avatar
    can you be a bit more specific?

    mine is GSM i think
    2012-11-10 12:55 AM
  4. GuiltyCookie's Avatar
    Should I maybe downgrade to 4.3.3 and unlock it from there? tinyumbrella has my ssh blobs saved.

    Please someone help
    2012-11-10 01:19 PM
  5. iYeow's Avatar
    Firmware can be downgraded if u have the blob but not baseband meaning you still won't be able to unlock it.
    2012-11-11 12:40 AM
  6. nrgonline's Avatar
    you cannot unlock with ultrasn0w or SAM. ultrasn0w only works with 01.59.00 baseband for iphone4.
    best thing you can do is buy a IMEI unlock service. deativate with redsn0w. activate in itunes and use your tmobile card.
    2012-11-16 04:32 AM
  7. Simon's Avatar
    If you are talking about O2 UK then if your contract is finished they should unlock it for you. Give them a call to find out.
    2012-11-16 05:08 AM
LINK TO POST COPIED TO CLIPBOARD