1. itjstagame's Avatar
    Hi all,

    Ok, so I have a Verizon 4S, 5.0.1, 1.1.13 BB, and I would like to use it with StraightTalk. I knew it had a GSM radio too and had seen how easy it is to use ST on an AT&T Iphone and only later realized that the CDMA version is harder to unlock.

    So I bought an R-SIM 5+ Ultra S and thought this would be no issue.

    I have been trying to follow the official instructions: R-SIM5 Ultra S Unlock Your iPhone4S IOS6.0,How to use,No cutting micro SIM card!Auto Detection!No call 112 or 911!Not jailbreak and install software!All Baseband

    I have chosen "USA Verizon" and I have tried "Other Mode 1 -> USA VER" and have even tried not picking any and editting IMSI with proper USA Verzion number: 2040400

    My issues are that while the radio will go to searching and will eventually come back with 3G and state in About as being "AT&T 11.0". It will not call or text and will always eventually revert back to saying it needs activation. (same as if I don't use the R-SIM, that is, same as invalid Sim).

    So further in the instruction it says for CDMA phones I need to JB and install CommCenter patch and TetherMe. My issue is that my Wifi does not work (broken on waterdamaged phone, "No Wifi"), but I did find CommCenter eventually and installed it manually using iFunBox after JB (at least I think it installed, there is no green 'check' next to it in Cydia).

    My question is, is TetherMe really required? I cannot seem to find it and from what I can tell it just allows tethering and CommCenter just allows modified carrier.plst, I don't see how either are supposed to help my activation/lack of true service problem.

    I have also tried deleting Zepplin carrier bundle as per here: How To Unlock CDMA iPhone 4S And Use It On GSM Network Using R-SIM [Guide]How To Arena
    But it also tells me to delete a file from /var/wireless/Library and this directory is empty on my phone (even after restore).
    Also when I remove the bundle then I cannot get my phone to activate and it just constantly says "Connect to Itunes".

    Is there any chance I need FuriousMod for some reason (even though this is R-SIM) ?

    Or is there someway to make this phone believe it's AT&T or unlocked phone instead of Verizon? Obviously there's no good way to remove/disable the CDMA hardware and I think this is part of my problem.

    This is annoying because when I got my R-SIM I activated my ST, so now I'm just losing days. Also I've tried the ST in my AT&T 4 and it works instantly without issue for calls and texts.

    Any help or suggestions is greatly appreciated, thank you.
    2012-11-30 08:24 PM
  2. youtashiro's Avatar
    I am in the almost very same situation dude... have a Verizon Iphone 4s 6.0.1 that I want to use with a Mexico GSM Carrier so I bought an RSIM V to unlocking it and didnt work, then bought the RSIM 5+ and didnt work eithet, I end every time with the Activation needed message.

    The thing is that I also have a Sprint Iphone 4s on 5.1.1 and both V and 5+ RSims works well with it. Have both phones with no jailbreak. I was thinking that the problem could be the ios version, but after reading this I am starting to thing that the problem has to do more with the carrier, maybe the verizon IMSI (2040400) is wrong or something like that. Will keep trying and get back if I find something.
    2013-01-20 02:39 AM