User Tag List

  1. jvito's Avatar
    I have an iPhone 4S that was originally on a regional CDMA carrier (Bluegrass Cellular), still has 5.1.1 and baseband 2.0.12. It is activated and functioning (works for emergency calls). I purchased a Gevey Ultra S designed for the CDMA phone (looks to be authentic as all the physical traits match up with the real thing). I installed the Gevey tray with the reset SIM, and then followed with my T-Mobile SIM.

    Being unsure which carrier info to use during the reset process, I tried multiple, with almost all of them kicking me out to the carrier activation required message (which goes away only when I remove the SIM). When I reset to a Verizon carrier, this message does not come up, but I show "no service" at the top of my phone screen. All methods get the Gevey "activation completed" message, and the Furious Mod code has been entered and accepted. So on a whim, after doing the unlock using the Verizon carrier for the reset again, I tried making a call with my T-Mobile SIM in the Gevey tray. The call worked. I can also call the phone from other locations. The phone can function on the T-Mobile network, but it always shows "no service". When I pull up the network properties in the "Settings" screens, there is nothing shown indicating an active T-Mobile carrier (still says Bluegrass Cellular). I am scratching my head over this and am wondering how to resolve the issue. This same T-Mobile SIM card fully works in a factory unlocked AT&T iPhone 4S that I have tried it in. I thought about trying to do a full restore on my 4S because someone had previously installed the SAM app from Cydia (since removed by me), but keep running into roadblocks with restoring to the 5.1.1 firmware while maintaining the 2.0.12 baseband (Apple sure has made it tougher to keep using older firmware since the last time I messed with this on my 3GS).

    Anyone have an idea of how to resolve this issue? I have spent tons of time trying to search the internet for answers, with no luck.

    2012-12-19 08:22 PM