User Tag List

  1. schummi2k's Avatar
    Discussion thread for Getting voicemail to work on unlocked iPhone. If you would like to add a comment, click the Post Reply button.
    2007-09-13 08:25 PM
  2. ~W~'s Avatar
    Can you clairfy a little on the VM? DOes this mean that T-Mobile supports visual VM? I'm a little confused...
    2007-09-13 08:42 PM
  3. Kyle Matthews's Avatar
    No. This just means when you click the voicemail button, it will call your voicemail. It is NOT visual voicemail. Apple already has T-Mobile support built in. This is for carriers who are not built in.

    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-09-14 01:06 AM
  4.'s Avatar
    It works ;-)) It only supports T Mobile US. I have TMobile in The Netherlands and that is not supported.
    Last edited by [email protected]; 2007-09-14 at 10:24 AM.
    2007-09-14 09:04 AM
  5. Kyle Matthews's Avatar
    T-Mo Netherlands should work fine with this tutorial, thats what it is meant for. T-Mobile in US requires no hacking other than the unlock itself.

    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-09-14 06:15 PM
  6. mvon919's Avatar
    Hi, I tied this, but my VM number is much longer! AT+CSVM command will allow only 3 numbers. Someone update something. Mine VM number is 10 numbers! (Elisa, Finland).
    2007-09-14 06:18 PM
  7. Kyle Matthews's Avatar
    Ah I see. Not sure then. Will look into it more...

    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-09-14 06:41 PM
  8. joerg's Avatar
    no, you cn just use a number that contains mor digits, t-mobile germany is 3311, worked well for me...
    2007-09-14 06:48 PM
  9. cynicguru's Avatar
    Sorry for this question...just successfully unlocked my phone with my sim card in Reykjavik, Iceland! I'm sure I'm the first one (and only one so far) in Iceland with a working iPhone. Anyway, the voice mail thingy....I'm just not "getting" the instructions. I can ssh into the iphone...but then it says "RUN". Where on earth do I find a "RUN" function? I'm using cyberduck. Am I missing something? I just can't figure out how to run all those commands. If someone could guide me in the right direction, I would be most appreciative.

    Cynic Guru
    2007-09-14 11:52 PM
  10. htdub's Avatar
    "Run" from a terminal window on your computer.

    I'm having trouble SSH into my iphone. It keeps disconnecting after a few sec's. I'm going thru terminal on my mac.
    2007-09-15 04:53 PM
  11. cynicguru's Avatar
    Run from a terminal window from your computer? Tried that...didn't work. I found these instructions to be pretty bad...

    "if you have set a SIM PIN, disable it (Settings>Phone>SIM PIN>off)
    ssh into your phone

    Okay...ssh into your phone...I've done that successfully with two different progs. Then is says simply, "run". Run with WHAT? None of the progs I've used to ssh into the phone have a RUN function. Could someone please clarify this for me a bit. Also, I'm on a mac (ppc)...thanks!!!!

    Cynic Guru
    2007-09-16 03:09 AM
  12. Mentch's Avatar
    Where the word "RUN" is, look below it for a dashed line box, and in the box is a command, type that command in the ssh program.

    So the first step would be to connect to SSH and make sure your in your phone, and then type the command: "launchctl unload -w /System/Library/LaunchDaemons/" without the quotes of course.
    2007-09-16 09:39 AM
  13. dougforman's Avatar
    Unlocked phone working great on t-mobile in US

    ssh into phone
    launchctl unload... ok

    # minicom
    minicom: WARNING: configuration file not found, using defaults
    minicom: cannot open /dev/modem: No such file or directory


    No modem?

    p.s. Sim PIN not set
    Last edited by dougforman; 2007-09-16 at 10:05 PM.
    2007-09-16 10:03 PM
  14. bharned3's Avatar
    what is the tmobil number to use foe the "xxx"
    Last edited by bharned3; 2007-09-18 at 02:40 AM.
    2007-09-18 02:20 AM
  15. maloo's Avatar
    I just killed my iphone with my crap attempts at using terminal, now have no phone network provider. If someone could help me with an idiots guide to getting voicemail working on telstra in australia, that would be gret. I also had problems with the posted procedure, and would like to get further advce on this. thanks, maloo
    2007-09-18 10:21 AM
  16. Gabster's Avatar
    Ok guys, here is a quick tutorial that i did to make my voicemail work (I am on Voda UK)...

    I did it on the Mac and make sure you have SIM lock off:

    1. Go to Application/Utilities/Terminal

    2. Type SSH [email protected]enter_your_iphone_ip_address

    3. Type dottie

    4. Copy & Paste the following: launchctl unload -w /System/Library/LaunchDaemons/

    5. Type minicom s

    6. Go down to Serial Port Setup and press enter

    7. Type a

    8. Change the port to /dev/tty.baseband

    9. Press Enter and then ESC

    10. Then Click Exit

    11. It should then say initializing modem

    12. Then type AT+CSVM=1,"xxx" (where xxx is the number you want to divert when pressing the voicemail button)

    13. You should get an OK message

    14. Press CTRL-a, then q

    15. Copy & Paste launchctl load -w /System/Library/LaunchDaemons/

    And you are done!!!

    Any problems please just say!
    2007-09-19 03:00 PM
  17. Kyle Matthews's Avatar
    This Wiki has been updated. Turns out Apple had this built in for an easy way to address it. Check the Wiki again.

    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-09-19 08:27 PM
  18. Qchar's Avatar

    The number that I need to dial to use VM is *501. I tried both methods (SSH and dial) and both does not work. Any ideas how to make VM shortcut working?

    2007-09-19 08:56 PM
  19. dsushee's Avatar
    Guys got the button working a treat , but my phone will not actually go to voicemail it just seems to either ring constantly or drop the call.

    I can only get it to go to voicemail if i "call forward" then everything goes to voicemail .. I'm on O2 in the UK.

    2007-09-20 12:02 AM
  20. ebling30's Avatar
    i'm getting this when trying to [email protected]

    Last login: Wed Sep 19 10:46:13 on console
    Welcome to Darwin!
    ebling:~ paulo$ SSH [email protected]"my ip add"
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @@@@@@@@@
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @@@@@@@@@
    Someone could be eavesdropping on you right now (man-in-the-middle attack)!
    It is also possible that the RSA host key has just been changed.
    The fingerprint for the RSA key sent by the remote host is
    Please contact your system administrator.
    Add correct host key in /Users/paulo/.ssh/known_hosts to get rid of this message.
    Offending key in /Users/paulo/.ssh/known_hosts:1
    RSA host key for "my ip add" has changed and you have requested strict checking.
    Host key verification failed.
    ebling:~ paulo$
    2007-09-20 01:42 AM
50 123