1. dhurley33's Avatar
    Can Somebody Please Help Me. I Followed All The Steps Of The Four Part Guide, And Everything Worked Perfectly Except At The Very End. Right After I Used Cyber Duck And Successfully Finished Those Steps, I Found The Unlock Padlock Icon On My Desktop. I Hit It, And Ran The Steps, After Waiting For 20 Minutes I Received The Success Notice. That Said Enjoy, Etc., But After Pressing The Home Key And Shutting Down The Device, I Put The T-mobile Sim In, And It Says No Service Still At The Top. I Don't Understand What I Should Do Next. I Have A Sidekick Iii And Thought This Would Work After Finishing All The Steps. I Even Tried To Enter Internet2.voicestream.com In The Apn Advanced Settings Of The Edge Network In Settings. Please Help Me So I Can Use My Iphone.
    2007-09-17 06:02 AM
  2. tomleewong's Avatar
    i did exactly what guide said but my fone still doesnt work with T moble.what can i do.please any one
    2007-09-17 07:42 AM
  3. cnicklo's Avatar
    Thanks for this amazing tutorial. Everything worked fine. My iPhone now is running on T-Mobile. I'm really greatful.

    A couple of things I had to work through, though to note:
    1) When I unzipped the restore file, for some reason all the unzipped items were invisible in their folder, so iNdependence couldn't view them (nor could I). I had to change the permissions of the folder and the files inside to make them visible.

    2) Cyberduck couldn't find my iPhone on its first try but worked like a charm on the second. I may have typed the "dottie" password incorrectly.

    3) My SIM is currently associated with a T-Mobile Blackberry plan. I had to use wap.voicestream.com to get Edge to work (which is the standard address for Blackberry). I first tried the same address you listed for the Total Internet service and it didn't work for me.

    Thanks again for everything. Hoping that the firmware update won't be too much of a challenge!
    2007-09-17 01:14 PM
  4. pez's Avatar
    I tried the anySIM after going through the ModMyI tutorial .. It had the credits screen with black bg and white font.. waited for minutes, more than 10, but nothing happened.

    I wanted to try iUnlcok Reloaded, but it didnt appear on the phone's screen. Now I am gonna try iUnlock, but i am really hopeless.. Why didn't anySIM go on...!?!??!

    any help would be highly appreciated!

    2007-09-17 05:03 PM
  5. camel67's Avatar
    tks ... amazing GUI ... all steps went like a breeze ... (maybe you need 1 hr total time).

    now waiting for the last 20 mins before inserting my sim card ...

    I will post the result.
    2007-09-17 07:00 PM
  6. elfribo's Avatar
    I did not add those, someone edited the Wiki. Those steps are not necessary, as CyberDuck already sets those permissions. Refresh the guide, it has been updated to be how I originally intended it.
    Completed all steps then when i ran the Duck entered my Phone IP which in my case and followed your steps server I get
    no connection error 3 times ( my MAC address is
    changed to that didn't work neither and I suppose I absolutely need
    to replace the lockdownd
    I have BSD and SSH previously installed and Commnities tools as well
    MY IPHONE WIFI is strong ( besides I am connected to Macbook with USB) not Docked.

    Do you have an idea why I cannot connect?
    Am I missing something or did somthing wrong>
    This is the second attempt to activate
    Iphone was restored in ITunes to 1.0.2

    Thank you very much for your insight.
    Last edited by elfribo; 2007-09-17 at 07:29 PM. Reason: typo
    2007-09-17 07:28 PM
  7. dandelion12345's Avatar
    yes, used sftp (SSH) and cyberduck app. Any input greatly appreciated. Thanks!
    2007-09-17 08:06 PM
  8. muffinman's Avatar

    Works flawlessly.

    Thanks again for providing the hands-down best unlock guide on the internet.

    MMi FTW!
    2007-09-17 10:14 PM
  9. iamspanky's Avatar
    i have an at&t activated phone but i want to unlock the sim cuz i will be traveling soon, do i just skip steps 1 and 2 and just proceed as normal from step 3? after unlocking it, will it effect anything such as voice mail even though im still using at&T?
    2007-09-17 11:06 PM
  10. nxovkin's Avatar
    very nice! followed the steps from poetic (like i always do) and everything works like a charm...phone is unlocked on first attempt and i'm a complete noob. i did do a complete restore on the phone to start with the unlocking. tested it out on my sister's t-mobile sim and was able to make and receive calls. i'm with at&t already but wanted to unlock the my iphone so i can use it overseas. thanks to poetic and everyone who made it possible for me to really enjoy my iphone.

    skip the activation part but you will still have to jailbreak you phone to continue with the unlocking process.

    i used my powerbook g4 to unlock my phone and it worked perfectly.
    Last edited by nxovkin; 2007-09-18 at 12:00 AM. Reason: Automerged Doublepost
    2007-09-17 11:22 PM
  11. ~W~'s Avatar
    so when you restore, it relocks again?
    2007-09-18 03:54 AM
  12. ckochosky's Avatar
    Any help for this you've found? Mine seems to be superduper painfully slow even before I actually run the 'unlock' icon.
    2007-09-18 04:49 AM
  13. micahman33's Avatar
    I just wanted to thank you for putting this tutorial together. It worked perfectly for me, including youtube. Everything is great, and I have been making calls with T-mobile all night. The only problem was my contacts on my sim werent showing up, but not a huge deal.

    Just as advice to anyone else who is starting this, the first couple steps messed up for me a couple times. Like the jailbreak was having problems. Just reset the phone and start again. Just read everything carefully and pay close attention, you can figure it out, its not hard at all.
    2007-09-18 08:27 AM
  14. Kyle Matthews's Avatar
    Glad it helped.

    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-09-18 08:28 AM
  15. dhurley33's Avatar
    Hello, Somebody please help me, I have unlocked the iphone using Mac OS X, closely and carefully following all the steps, from the firmware update in part 1, to the independece activation success, and cyberduck successful transfers to usr/libexec and applications, and then selected the padlock icon "unlock" on the desktop where after waiting for about twenty minutes received the "enjoy" icon. I than restarted my iphone popped in the T-Mobile sim, and NO SERVICE is all I get. I can not find a post like this in the Mac Modding, or anywhere with somebody that can help me get this phone working. After restarting phone with T-Mobile sim several times, I still have NO SERVICE displayed. I have went into carrier settings and can only choose between automatic and manual, T-Mobile is not even an option. I have also adjusted the EDGE settings to work with my data plan. I have full access of everything from Wi-Fi access to YouTube, but no phone signal. This is the second time I have restored my phone. Do you think it's my sim card. I have been using a T-Mobile Sidekick 3, and once performing the unlock on the iphone I swapped out the sim card. I know the Iphone recognizes my T-Mobile sim because it says my phone number in phone settings, however still displays NO SERVICE. Please help me so that I can make and receive calls/and SMS. This is getting to be ridiculous.
    Last edited by dhurley33; 2007-09-18 at 08:48 AM.
    2007-09-18 08:43 AM
  16. Kyle Matthews's Avatar
    Do you not have service in that area?

    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-09-18 08:44 AM
  17. sandy44's Avatar
    I tried the anySIM after going through the ModMyI tutorial .. It had the credits screen with black bg and white font.. waited for minutes, more than 10, but nothing happened.

    I wanted to try iUnlcok Reloaded, but it didnt appear on the phone's screen. Now I am gonna try iUnlock, but i am really hopeless.. Why didn't anySIM go on...!?!??!

    any help would be highly appreciated!

    What version of anySIM were you using? I heard that there were some timing issues in the version 1.0 which were fixed in version 1.0.1. Try downloading the newer version and give it a shot. Hopefully it works !!
    2007-09-18 04:21 PM
  18. micahman33's Avatar
    Your problem isnt that crazy. My phone reported "no service" for the first couple minutes when I put my sim in. I just let it sit there for awhile and eventually it found the T-mobile signal. I havent had problems with it since.
    2007-09-18 05:12 PM
  19. Sage's Avatar
    I did it! Thanks a million PF! I was having problem opening SSH connection to my phone. So I uninstalled the OpenSSH from Installer, then installed SSH with iNdepedence. Then it worked. Although YouTube isn't working for me, any idea why?
    2007-09-18 06:19 PM
  20. msc1974's Avatar
    Big thanks to all involved, followed the instructions and work first time. There are now 4 members to my family, I love the iPhone. Thanks everyone.
    2007-09-18 08:39 PM
156 12345 ...