1. grant.ben08's Avatar
    I am at my mother in law's house and my iPhone 4 will not retain the wifi connection. As soon as my phone goes to sleep and loses connection I have to re-enter the password. There are 3 other iPhone 4s in this house and all I them on 5.1.1. My phone is jailbroken and so is my wife's. My phone is the only one having an issue. I have tried resetting network settings and it still doesn't stay connected. Any suggestions?
    2012-08-19 03:48 AM
  2. H4CK3R's Avatar
    Are you jailbroken by chance? If you are, try it in safe mode and see if it persists, that will narrow down the possibilities a bit.
    2012-08-19 04:13 AM
  3. kamleshchimba's Avatar
    Just to clarify..is there any other unlocked or jailbroken iphone in the house? What is the status for that iphone? Is it getting the network regularly? Which application did you use for jailbreaking your iphone? Actually I'd the same problem with my earlier iphone3, but I used UltraSnow.eu jailbreak application for 4S and its working better now. I think you need to recheck your jailbreaking options once again.
    2012-08-24 08:10 AM
  4. i.Annie's Avatar
    As the others have suggested, it could be a jailbreak tweak/addon that is causing the issue. I agree with H4CK3R's suggestion, if the problem doesn't persist with all mobilesubstrate addons disabled, then it is a jailbreak tweak/addon causing the issue. If you find this to be true, you can disable each mobilesubstrate addon from SBSettings under More>Mobilesubstrate addons to find your culprit.
    2012-08-24 09:14 AM
  5. scorpluto's Avatar
    better go to the apple store, if you can do it with yourself better have an apple specialist sees it.
    2012-08-28 12:44 PM
  6. H4CK3R's Avatar
    better go to the apple store, if you can do it with yourself better have an apple specialist sees it.
    It's software related, not hardware. I can pretty much guarantee that the only thing they'd do at the store is restore it. Besides, he's jailbroken, so I'm pretty sure he doesn't want to lose his jailbreak.
    2012-08-28 12:45 PM
  7. grant.ben08's Avatar
    Sorry for getting back to this so late, I thought i was subscribed to this thread but apparently I wasn't.
    There were 2 jailbroken phones but only mine was having the issue. The router I was on was my mother in laws and it went down and had to be reconfigured. I got envolved in the reconfiguration and now everything is fine. Thank you for you all for the help and the suggestions though.
    2012-09-06 01:38 PM
  8. H4CK3R's Avatar
    Glad it's fixed
    2012-09-06 09:39 PM
LINK TO POST COPIED TO CLIPBOARD