1. iphonebitch13's Avatar
    Discussion thread for Dev Team Installing SSH 1.1.1 OSX. If you would like to add a comment, click the Post Reply button.
    2007-10-11 09:26 AM
  2. mex_24's Avatar
    I tried to follow the procedure and everything was going as in the webpage, but by the time I had to test the ssh and enter my iphones ip address i got the message "ssh: connect to host 192.168.1.8 port 22: Connection refused" and could not move from there...know any way to fix this?
    cheers!
    2007-10-11 11:18 AM
  3. dotmotion's Avatar
    I keep getting the "cannot execute binary file" error while running iPhoneMacSSHInstall.sh

    Is there anything I'm missing? (I'm sure it's jailbreaked cause I didn't had the iTunes_Control thing there on the ls while running iPhuc
    Last edited by dotmotion; 2007-10-11 at 01:55 PM.
    2007-10-11 01:45 PM
  4. Chris3k2's Avatar
    can somebody help me? When i go to verify whether or not ssh worked it times out on me. I put " ssh -l root and my ip address" but it times out. Why is this? did it not work?
    2007-10-11 07:26 PM
  5. steve_k's Avatar
    my step 4 screen looks different from the one posted? anyone have this problem?
    2007-10-11 08:03 PM
  6. Eurisko's Avatar
    can somebody help me? When i go to verify whether or not ssh worked it times out on me. I put " ssh -l root and my ip address" but it times out. Why is this? did it not work?
    If it times out, try again. The first time you SSH in, it needs to generate a key so it can take 40 to 60 seconds.
    2007-10-11 08:06 PM
  7. steve_k's Avatar
    how do i find my iphones ip?
    2007-10-11 08:12 PM
  8. Eurisko's Avatar
    how do i find my iphones ip?
    Goto Settings -> WIFI -> [Name of your router] and you'll see your IP.
    2007-10-11 08:18 PM
  9. steve_k's Avatar
    i can't go to that setting functions yet. i'm on step 7 for the http://modmyi.com/wiki/index.php/Dev..._SSH_1.1.1_OSX guide. my phone isn't activated yet.
    2007-10-11 08:25 PM
  10. Chris3k2's Avatar
    i don't have a real stable wi-fi connection... Could this be why i'm repeatedly getting a timed out error?
    2007-10-11 08:45 PM
  11. gnewt's Avatar
    If it's timing out, chances are you got it right and it's doing the password thing... sometimes you may have to do it a few times for it to really work. If it didn't work at all you'll get the message "Connection refused."

    This script appears to be horrendously broken. Note that even in the tutorial all sorts of errors appear.

    For me, the iphoneinterface app included doesn't run... I get the same message as dotmotion. I've tried building from source, which was successful but it still didn't execute. I'm using a PPC Mac. I'll post more info as I get it in case others have the same issue.
    2007-10-11 08:59 PM
  12. steve_k's Avatar
    so i was trying to access my phone and now it won't even connect to itunes i'm getting a error code. i don't know how to fix it! =(
    2007-10-11 09:38 PM
  13. Chris3k2's Avatar
    mine did that and i just did a restore to 1.1.1 and then redid the downgrade and just went back over everything again.
    2007-10-11 09:50 PM
  14. seaofclouds's Avatar
    i keep getting stuck on phase 1"

    --------PHASE 1: Getting files off your iPhone---------

    ./iPhoneMacSSHInstall.sh: line 17: ./iphoneinterface: cannot execute binary file

    mv: com.apple.update.plist: No such file or directory


    --------PHASE 2: Uploading files and reconfiguring your iPhone---------

    ./iPhoneMacSSHInstall.sh: line 33: ./iphoneinterface: cannot execute binary file

    --------PHASE 3: Restarting your iPhone---------

    Press and hold the Power button on your iPhone until it shows the 'slide to turn off' red slider.
    Slide it, wait for the phone to turn off, and press the power button to turn it on again.

    Press Enter to continue...
    my phone's jailbroken, as i've just confirmed all of the steps for jailbreaking 1.1.1. any tips? or, is there a way to install apptapp installer directly? then, i could install ssh/sftp through apptapp.
    2007-10-12 09:57 PM
LINK TO POST COPIED TO CLIPBOARD