1. hauler34's Avatar
    Discussion thread for Dev Team Installing SSH 1.1.1 Windows. If you would like to add a comment, click the Post Reply button.
    2007-10-11 10:07 PM
  2. originalg00ksta's Avatar
    can anybody tell me why i can't connect to ssh after doing everything correctly?
    2007-10-11 10:23 PM
  3. stlcaddie's Avatar
    yea im having that same problem like a bunch of other people. I know what im doing and ive followed the directions 20 different times.....i keep getting network error:connection failed......OH YEAH IM ON WINDOWS WITH WINSCP
    2007-10-11 11:17 PM
  4. jcj3582's Avatar
    i'm having the same problem - even tried using apline as the password.
    2007-10-12 12:16 AM
  5. papabro's Avatar
    yea im having that same problem like a bunch of other people. I know what im doing and ive followed the directions 20 different times.....i keep getting network error:connection failed......OH YEAH IM ON WINDOWS WITH WINSCP
    I am in the exact same situation. Additional info: when trying to connect using ftp I can see the following:

    Connecting to 'my ip'
    Connected to 'my ip'. Waiting for welcome message....

    The I get the connection failed popup.

    Any ideas?
    2007-10-12 01:05 AM
  6. Aznareuz's Avatar
    in the Phase 1, it goes like this,
    --------PHASE 1: Getting files off your iPhone---------

    s_iPhoneInterface
    s_Waiting for phone
    Could not enable SSL
    s_Connection established.
    e_Not jailbroken
    r_command
    r_command
    fileref: 1
    r_command
    r_command
    fileref: 1
    r_command
    A duplicate file name exists, or the file
    cannot be found.
    A duplicate file name exists, or the file
    cannot be found.

    1 file(s) copied.
    1 file(s) copied.

    is it ok?
    2007-10-12 05:15 AM
  7. y0haan's Avatar
    Same problem here.

    You may want to see if this link works.
    http://www.modmyi.com/wiki/index.php..._1.1.1_Windows

    Check the bottom of the page where is says Troubleshooting.
    It does not work for me but if someone can try it.

    When I run iphoneinterface from dos I get this:

    CiPhoneIII\SSH>iphoneinterface
    s_iPhoneInterface
    s_Waiting for phone
    s_Connection established.
    e_Not jailbroken
    r_command
    putfile /System/Library/LaunchDaemons/au.asn.ucc.matt.dropbear.plist

    But then the iphoneinterface get an error and closes.

    Finally got it working, Thanks to geoffl1.



    Download the sshkit.zip here
    http://devices.natetrue.com/iphone/sshkit.zip

    Then you will need to copy iphoneinterface from the newest copy of iBrickr which you can get here http://ibrickr.com/downloads/ibrickr_v0.91.zip

    Then redue the instructions here from Step 2http://modmyi.com/wiki/index.php/Dev_Team_Installing_SSH_1.1.1_Windows
    Last edited by y0haan; 2007-10-12 at 07:52 AM. Reason: Automerged Doublepost
    2007-10-12 07:52 AM
  8. unt_eagle_69's Avatar
    Im having issues when i load up winscp using these settings

    IP Address: my IP
    Login Name: root
    Password: alpine
    Connection Type: SCP
    Port: 22

    it tell me there is an error with the groups command

    got any ideas am i all alone on this one?
    Last edited by unt_eagle_69; 2007-10-12 at 10:41 PM. Reason: Automerged Doublepost
    2007-10-12 09:59 PM
  9. plmars's Avatar
    I did that and i still can not connect


    Same problem here.

    You may want to see if this link works.
    http://www.modmyi.com/wiki/index.php..._1.1.1_Windows

    Check the bottom of the page where is says Troubleshooting.
    It does not work for me but if someone can try it.

    When I run iphoneinterface from dos I get this:

    CiPhoneIII\SSH>iphoneinterface
    s_iPhoneInterface
    s_Waiting for phone
    s_Connection established.
    e_Not jailbroken
    r_command
    putfile /System/Library/LaunchDaemons/au.asn.ucc.matt.dropbear.plist

    But then the iphoneinterface get an error and closes.

    Finally got it working, Thanks to geoffl1.



    Download the sshkit.zip here
    http://devices.natetrue.com/iphone/sshkit.zip

    Then you will need to copy iphoneinterface from the newest copy of iBrickr which you can get here http://ibrickr.com/downloads/ibrickr_v0.91.zip

    Then redue the instructions here from Step 2http://modmyi.com/wiki/index.php/Dev_Team_Installing_SSH_1.1.1_Windows
    2007-10-13 02:56 AM
  10. unclear's Avatar
    Im having issues when i load up winscp using these settings

    IP Address: my IP
    Login Name: root
    Password: alpine
    Connection Type: SCP
    Port: 22

    it tell me there is an error with the groups command

    got any ideas am i all alone on this one?
    the GROUPS command error is normal, I get it too.

    By the way, just overhauled the SSH guide (among others)

    try starting it from scratch

    Made a fix for this GROUPS error...
    http://www.modmyi.com/forums/showthr...light=bsd_more
    Last edited by unclear; 2007-10-13 at 10:13 AM. Reason: Automerged Doublepost
    2007-10-13 10:13 AM
  11. y0haan's Avatar
    I did that and i still can not connect
    Hi plmars,

    Did you get the same output as Aznareuz when performing Step 2?
    I believe when it did not work I had the same output.

    I just made sure I grabbed all the latest files from the links given. Then ran through the instructions again and it worked. Pay attention to the note in Step 2. I actually turned of wifi all together & turned it back on after my last reset.

    the GROUPS command error is normal, I get it too.

    By the way, just overhauled the SSH guide (among others)

    try starting it from scratch

    Made a fix for this GROUPS error...
    http://www.modmyi.com/forums/showthr...light=bsd_more
    Thank you, I was looking for those.


    Does anyone get this message when logging into winSCP

    The server's host key was not found in the cache. You have no guarantee that the server is the computer you think it is.
    The server's rsa2 key fingerprint is:
    ssh-rsa 1024 94:3c:9e:2b:23:df:bd:53:b4:ad:f1:5f:4e:2f:9d:ba


    I also say No, but wondered if anyone said Yes and if the message went away. Also, does anyone think it is safe to say Yes to that message?
    Last edited by y0haan; 2007-10-13 at 10:31 AM. Reason: Automerged Doublepost
    2007-10-13 10:31 AM
  12. unclear's Avatar
    Yea, you wanna say Yes to that... It may take a minute as it generate some key files or something.. After that you shoudn't get the message again.
    2007-10-13 11:02 AM
  13. apollo18's Avatar
    I kept getting the "connection refused" error from WinSCP, even after following the Troubleshooting step.

    What worked for me was using the instructions posted on the dev team's wiki:
    http://iphone.fiveforty.net/wiki/ind...nstall_OpenSSH
    2007-10-14 12:35 AM
  14. EsotericDude's Avatar
    Mine failed too. I'm going to show EXACTLY what I did in hopes you can help me.
    When I extracted ssh.rar and ran the sshify-windows.bat, I received the same errors on phase 1 as Aznareuz and the end result after restarts was no ssh connection:
    --------PHASE 1: Getting files off your iPhone---------

    s_iPhoneInterface
    s_Waiting for phone
    Could not enable SSL
    s_Connection established.
    e_Not jailbroken
    r_command
    r_command
    fileref: 1
    r_command
    r_command
    fileref: 1
    r_command
    A duplicate file name exists, or the file
    cannot be found.
    A duplicate file name exists, or the file
    cannot be found.
    1 file(s) copied.
    1 file(s) copied.
    After inspecting the batch file, I deleted the entire ssh folder that I had extracted to and started over.
    I then looked at the two lines causing the error:
    ren com.apple.update.plist com.apple.update.plist.orig
    ren update update.orig
    I deleted the update.orig file and com.apple.update.plist.orig so that these two operations would complete properly.
    I then ran the sshify-windows.bat with the following output:

    --------PHASE 1: Getting files off your iPhone---------

    s_iPhoneInterface
    s_Waiting for phone
    s_Connection established.
    e_Not jailbroken
    r_command
    r_command
    fileref: 1
    r_command
    r_command
    fileref: 1
    r_command
    1 file(s) copied.
    1 file(s) copied.

    --------PHASE 2: Uploading files and reconfiguring your iPhone---------

    s_iPhoneInterface
    s_Waiting for phone
    s_Connection established.
    e_Not jailbroken
    r_command
    fileref: 1
    r_command
    fileref: 1
    r_command
    fileref: 1
    r_command
    fileref: 1
    r_command
    fileref: 1
    r_command
    r_command
    fileref: 1
    r_command
    fileref: 1
    r_command
    fileref: 1
    r_command
    fileref: 1
    r_command
    fileref: 1
    r_command
    r_command
    fileref: 1
    r_command
    fileref: 1
    r_command

    --------PHASE 3: Restarting your iPhone---------

    Press and hold the Power button on your iPhone until it shows the "slide to turn off" red slider.
    Slide it, wait for the phone to turn off, and press the power button to turn it on again.
    Press any key to continue . . .

    At this point I rebooted the iPhone and waited several minutes (while writing this documentation). I then rebooted again (as suggested in dox) and waited several more minutes.

    I then continued the batch file and it gave me the following output:

    --------PHASE 4: Putting init framework into place---------

    1 file(s) copied.
    1 file(s) copied.
    s_iPhoneInterface
    s_Waiting for phone
    s_Connection established.
    e_Not jailbroken
    r_command
    fileref: 1
    r_command
    fileref: 0
    r_command
    --------PHASE 5: Restarting your iPhone, again---------

    Restart your phone once more. After that, you're done!
    Press any key to continue . . .
    As suggested by the guide I then ran iphoneinterface here's a the output of exactly what I did:
    s_iPhoneInterface
    s_Waiting for phone
    s_Connection established.
    e_Not jailbroken
    r_command
    putfile /System/Library/LaunchDaemons/com.apple.update.plist
    fileref: 1
    r_command
    exit
    I then shutdown the iPhone and restarted it and waited several more minutes. I then attempted to connect via winscp to no avail. I also tried to connect directly to port 22 via telnet (to see if it was active):
    Diphone2\SSH>telnet 192.168.1.2 22 (I know this is the address of the iphone as that's what the wifi shows in settings)
    Connecting To 192.254.173.2...Could not open connection to the host, on port 22:
    Connect failed

    After that I re-placed dropbear as suggested in troubleshooting:

    s_iPhoneInterface
    s_Waiting for phone
    s_Connection established.
    e_Not jailbroken
    r_command
    putfile /System/Library/LaunchDaemons/au.asn.ucc.matt.dropbear.plist
    fileref: 1
    r_command
    I then rebooted my phone, still no SSH. HELP

    I kept getting the "connection refused" error from WinSCP, even after following the Troubleshooting step.

    What worked for me was using the instructions posted on the dev team's wiki:
    http://iphone.fiveforty.net/wiki/ind...nstall_OpenSSH
    Thanks your suggested guide worked!!! (However, I still had to iphoneinterface the putfile /System/Library/LaunchDaemons/com.apple.update.plist at the end of sshifty-windows[\b] FYI, I know other dox show this, but the password in 1.1.1 is alpine.
    I finally can move on.
    Last edited by EsotericDude; 2007-10-14 at 01:01 AM. Reason: Automerged Doublepost
    2007-10-14 01:01 AM
  15. minhchu58's Avatar
    I have the problem to run winscp. Even i tried so many time and different way. could you please show me the way to get winscp work. when I install shh every thing good but when I use winscp the connection refuse . I tried so many time but the same. please help me !!!!
    2007-10-26 06:04 PM
  16. Eurisko's Avatar
    Is this also suppose to fix the problem where you actually can successfully log into your phone but then you're disconnected when trying to enter a command?
    2007-10-26 06:52 PM
LINK TO POST COPIED TO CLIPBOARD