1. liontos's Avatar
    Discussion thread for Downgrade Baseband 1.1.1 to 1.0.2 OSX. If you would like to add a comment, click the Post Reply button.
    2007-10-12 08:33 AM
  2. lwmang's Avatar
    I might be the only one but... it worked when it unlocked it with anysim, but the final step caused the phone to say incorrect sim again, even though its the same ATT sim that came with the phone.
    2007-10-12 07:13 PM
  3. tmas73's Avatar
    I am getting stuck at step 12:

    My terminal message looks like this.

    Last login: Fri Oct 12 09:57:11 on ttyp1
    Welcome to Darwin!
    tmas73:~ tmas73$ ssh -1 root
    ssh: root: No address associated with nodename
    tmas73:~ tmas73$


    The tutorial has a "1" instead of a "l"

    WRONG: tmas73$ ssh -1 root
    RIGHT: tmas73$ ssh -l root
    Last edited by tmas73; 2007-10-12 at 08:42 PM.
    2007-10-12 08:21 PM
  4. Primpilampa's Avatar
    I have Modem Firmaware 04.01.13_G and everything is working OK, should I keep it this way?? Everything works fine, even phone.

    2007-10-12 08:31 PM
  5. tmas73's Avatar
    I have following error.

    # ieraser
    Resetting the Baseband...Done
    Opened: /dev/tty.baseband
    iEraser: tool by geohot
    thanks to gray and the dev team for the implementation
    thanks to nightwatch for the awesome toolchain
    and thanks to anonymous, iProof, lazyc0der, and dinopio for the idea for this cool trick
    this tool erases your main fw, starting at 0x20000. you need this for the testpoint to work
    you need a file called secpack matching your current firmware version in this folder
    see http://iphonejtag.blogspot.com for instructions on finding this file
    Waiting for data...
    Got Header: 77 0b cc
    zsh: bus error ieraser

    Any info?
    2007-10-12 08:51 PM
  6. noar's Avatar
    this metod will work with a brand new out of the box iphone?
    2007-10-12 10:47 PM
  7. djcarly's Avatar
    will this method also work with a 1.1.1 "out of the box" and what will happen with the imei number?

    thanks in advance
    2007-10-13 12:29 AM
  8. lucafer69's Avatar
    Hi. How do I access TERMINAL? Its not in the utility file.
    2007-10-13 12:33 AM
  9. iphone03's Avatar
    For Step Four how you said then comes up bla bla and blablaa is it on the page it says bla bla bla or like lots of writing
    2007-10-13 02:07 AM
  10. mochaholic's Avatar
    # bbupdater -v
    Resetting target...
    pinging the baseband...
    issuing +xgendata...
    firmware: DEV_ICE_MODEM_04.01.13_G
    eep version: EEP_VERSION:207
    eep revision: EEP_REVISION:8
    bootloader: BOOTLOADER_VERSION:3.9_M3S2
    # ieraser
    zsh: permission denied: ieraser

    i always get this message, i am stuck with #12, pls help
    2007-10-13 04:50 AM
  11. Nemesis45's Avatar
    Well i have a problem i'am able ssh to my iphone but when i try to unload com.apple.commcenter i get an error:no such process also when i try to access the file system for example: USR/BIN/ i get zsh: permission denied: message plz! help i really need this

    thanks for ur time!!!
    2007-10-13 05:08 AM
  12. bobsmith101's Avatar
    Last edited by bobsmith101; 2007-10-13 at 10:39 PM. Reason: Fixed - my mistake
    2007-10-13 01:29 PM
  13. jgasca's Avatar

    It is case sensitive, try :

    # launchctl remove com.apple.CommCenter


    This downgrade process works perfectly, I bought my iphone with 1.1.1 and baseband firmware: DEV_ICE_MODEM_04.01.13_G.
    I followed the process and now I'm at: 1.0.2 and baseband firmware: DEV_ICE_MODEM_03.14.08_G.

    But when I run AnySim to unlock, it always ends with this error : " 'unlock failure the flash operation succeded but the unlock commands failed. you might want to check the baseband manually using minicom' " and it still wont let me to use a non AT&T SIM.

    Any ideas?

    Thanks for any help
    Last edited by jgasca; 2007-10-13 at 04:23 PM. Reason: Automerged Doublepost
    2007-10-13 04:23 PM
  14. crazysev29's Avatar
    for some reason my terminal wont let me type the password (dottie).

    Any suggestions??
    Unlock iPhone successful!! thanks modmyi!!
    2007-10-13 08:25 PM
  15. dbrown0690's Avatar
    Really frustrated now. All I wanted to do was upgrade and I HAD and perfectly happy locked phone that behaved. This tutorial instructed unlocking then locking again (not sure why) but being the trusting little lemming that I am, I did so. Then when I tried to run the Jailbeaking tutorial for 1.1.1, got an invalid SIM error. Now I can't do anything as it seems to lock out any sort of activation via iNdependence or anything. I have the original SIM in place. How do I get to the step where I can re-flash the Baseband and factory restore my SIM? I am assuming it is possible or am I totally screwed at this point? A quick response is vital as I am on call at the hospital and really need my phone to make calls. Thanks
    2007-10-13 11:45 PM
  16. bobsmith101's Avatar
    I used this method to unlock a 1.1.1 iphone out of the box.

    Everything went well.

    In the end the phone was unlocked and can dial.

    But I have two problems. The the WiFi connection constantly disconnects and the volume is very low during a call.

    Any ideas?
    2007-10-14 01:15 AM
  17. goastros's Avatar
    I'm so frustrated... everything seems to be perfect. i've restored the 1.0.2 firmware and also successfully downgraded the modem, installed and ran anySIM but it still says that i have an incorrect SIM. what have I done wrong or what do I still have to do. I'm not kidding i may give my first born to who ever can help me.
    2007-10-14 02:28 AM
  18. dbrown0690's Avatar
    For whatever reason, I am getting the message in step four/five when launching iNdependence: "Failure- Connection failed: Phone was not paired. Make sure you run iTunes with your phone connected at least once." Well, there's the rub, now isn't it? How am I supposed to connect when I have an invalid SIM? Is there something I am missing? How do I get past this stage? I looked into iASign but it looked rather complicated and most solutions require the phone to be jailbroken. I had it out of jail once but could not get past the activation screen to run the installer app. Any thoughts? Thanks.
    2007-10-14 03:08 AM
  19. tmosesi's Avatar
    I followed all the steps and everything went through without a glitch. However when I switched to a different SIM (prepaid tmobile), I got an error message again saying that I have the wrong SIM and should connect to iTunes to activate. When i connect to iTunes I get the same annoying error message as before. Any fixes for this?
    2007-10-14 08:30 PM
  20. JoeJITSU's Avatar
    Is there a windows version?
    2007-10-14 09:52 PM
59 123