1. IconBoy's Avatar
    Have you been tearing your hair out because you can never get WinSCP to connect no matter what you try with all the suggestions people have given you? I was in the same boat and now I get WinSCP connecting all the time!

    I had some techy-guys at the university here give me some help and now I am a happy-chappy!

    My setup:
    Win XP SP2
    iPhone 1.1.4 (1st Gen)
    USB Hawking Wireless dongle

    R-click on your wireless network icon in your systray.
    View Available Wireless Networks
    Change advanced settings.
    Choose Wireless Networks (2nd tab)
    Network name (SSID): "hoorayitworks" (or whatever you would like to call it - no quotes)
    Network Authentication: Open
    Data encryption: Disabled
    Check the box: This is a computer-to-computer (ad hoc) network); wirless access points are not used.

    Choose General (1st tab)
    Scroll down "This connection uses the following items:" list and highlight Internet Protocol (TCP/IP). Click on Properties.
    Enable "Use the following IP address" and type in something generic e.g.:
    IP address: (the techy guys said use 192.168 and then add two sets of numbers to 192.168.nnn.nnn (where nnn is between 1 and 254).
    Subnet mask:
    Click OK then OK.

    On your iPhone, choose Settings | WiFi.
    Choose "hoorayitworks" and you will see the check mark added to it.
    Then touch the little blue/white arrow to the right of it.
    Choose Static.
    IP address: (Make it one greater than the one you did on the PC).
    Subnet mask:
    Touch WiFi Networks | Settings then Home button.

    Open WinSCP
    Click on New.
    Host name: (this is the iPhone IP).
    Username: root
    Password: alpine (or dottie if older firmware).
    Protocol: SFTP (Check allow SCP fallback)
    Save session (with or without password remembered - your choice)
    Login (and you should see Search for host... Connecting to host... etc. It may take a good few seconds to get that initial login.)

    I even used the WinSCP settings in Filezilla and can connect to my iPhone.
    If I want to go on the internet, I just change my iPhone WiFi settings back to the wireless (non ad-hoc) point once I am done with SFTPing into the phone.

    Hope this helps and others can (finally) connect to their phones.
    Last edited by IconBoy; 2008-08-02 at 01:28 AM. Reason: Updated info
    2008-08-01 11:05 AM
  2. YellowCopy's Avatar
    When I read this earlier I was just getting ready to post up a question on what was I doing wrong. I have tried at least 4 other ways to get files to the phone and was getting to be rather frustrated.

    One thing, I dunno if this is a difference between sp2 and sp3 but I had to add this step.

    Under Network connections > r-click on wireless connection network to get to view available wireless networks.

    On that screen L-click on the network for the ssh, then on the left part of that window click on the option of "change advanced settings".

    Tab over to wireless network connection properties, wait for the bottom options to un-grey themselves, click on the name of the ssh network and hit properties.

    Under association, verify that the top box of "Connect even if this network is not broadcasting" is checked and under the connection tab the box for "connect when this network is in rage" is checked too.

    Otherwise it will connect and then I kept on losing the connection as it would close from inactivity.

    After I figured that out it worked like a charm! Thanks alot for the help man!!

    Hardware, Belkin Wireless G desktop PCI card, windows xp SP3, iPhone 3G 8GB
    2008-08-02 02:24 AM