1. ggallo's Avatar
    Installed ssh, got it working, modified master.passwd using r00t4rd3d's web page to generate encrypted password, cut and pasted it below the orignial content then deleted original content in master.passwd.

    Restarted WinSCP and tried to ssh with new password. No dice.
    tried to login with old password. No dice.
    Compared original master.password with the replacement. Only difference is a carriage return at the end of the original. Knowing how picky UNIX is I suspect that my master.password is corrupt now without that carriage return.

    Phone still works fine, just can't ssh and continue modding. Do I have to do a recovery/restore or is there another way to restore the original master.passwd? This was my first mod so there's no other apps or tools on the phone, no binkit or terminal.

    Is there some way to fix it using jailbreak?

    Ok, just discovered iphonebrowser and all is well now. Thanks cranium. Sorry for the noob noise. Carry on.
    Last edited by ggallo; 2007-08-21 at 04:05 AM. Reason: Automerged Doublepost
    2007-08-21 02:33 AM
  2. bigdogjonx's Avatar
    Yeap iphoneinterface or iphonelist or manzana can help you replace the original file. But speaking on this, I could not get it to work with numeric and capital letters, such as 123Password, it wouldnt work, had to use something like password. When using numeric and capital letters I noticed the XU salt part was XU.encryptedpassword instead of the normal XUencryptedpart.

    Dixit
    2007-08-21 07:15 AM
  3. ggallo's Avatar
    Yeah, now that I got the file replaced and fixed the carriage return, it still wouldn't work with the password I chose. I'll try it again with no numbers in it. Thanks.
    2007-08-21 07:29 PM
  4. weyerma's Avatar
    This works:
    http://pastebin.ca/904464

    Replace this with /etc/passwd
    2008-02-21 01:44 AM
  5. jeffreyfu's Avatar
    Hi all,

    I changed my passwd in the Iphone Terminal and now it keeps rebooting("Edit Home Screen" message keeps poping up). Then, I use ssh from my laptop to login to iphone using my new password and update the master.passwd with the master.passwd listed in http://pastebin.ca/904464(previous post). So the root password has change to *(root:*:0:0:System Administrator:/var/root:/bin/sh) instead of the encrypted new password. It didn't solve the problem("Edit Home Screen" popping up) and now I can't login to my Iphone using SSH because the password has change to "*". I don't know how to restore it. Can I restore the firmware to 1.1.4 with iTune and unlock it again? My Iphone firmware was originally shipped with 1.0.2, upgrade to 1.1.4 by iTune and then iPlus unlock. Does anyone have the original master.passwd that can share with me? Is there any tool to copy this original master.passwd to my iphone without ssh login? I heard that iphonelist can do that. But not sure about it.

    Please help me....many thanks
    2008-03-27 07:19 PM
LINK TO POST COPIED TO CLIPBOARD