1. NurkJon's Avatar
    Well I came across this command-line tool named iTunnel which let you tunnel data via usb to your iPhone, I couldn't find who've made the tool but mad creds to that person anyway it weren't a very user friendly tool so I created a simple lightweight gui for it which supports ssh vnc and tethering and I've included WinSCP, Putty, TightVNC, UltraVNC,Portable Firefox. There are easy to follow help menus also for those who might not understand. So it's a small simple handy tool that is very useful.

    A screenshot of the program

    Website(temporary website at the moment): NurkJons Temporary Website
    Download iUSB Tunnel installer: http://nurkjon.com/files/iUSBTunnelInstaller.exe
    Download iUSB Tunnel as a zip:http://nurkjon.com/files/iUSBTunnel.zip

    I hope that this tool will be useful to someone. Please comment what you think about it.
    2009-05-10 07:44 PM
  2. lach's Avatar
    2009-05-11 09:29 AM
  3. NurkJon's Avatar
    I'm glad you like it. I hope more people will find this program useful. If you find any bugs please tell me.
    2009-05-11 11:06 PM
  4. FramedTrash's Avatar
    i cant get it to work
    i have SSH turned on and my phone connected to pc via usb
    i try to connect via WINSCP and i just get a "network error"
    what am i doing wrong
    2009-05-12 06:45 AM
  5. NurkJon's Avatar
    Well first make sure that you connect to (there should be a premade profile in winscp named iphone) also make sure that you've started iTunnel under ssh first before you start winscp and of course you're iphone cable must be connected.
    2009-05-12 06:53 AM
  6. FramedTrash's Avatar
    ahhh perfect that worked
    need to hit itunnell before you hit WINSCP
    works a treat
    this is great coz in my office i dont have wifi access
    2009-05-12 07:12 AM
  7. ifonemod's Avatar

    i am having a problem with SSH/WinSCP

    i opened up iUSB Tunnel then i opened iTunnel and i clicked on WinSCP, when i click on Login it gives me an error:

    "Network error: Software caused connection abort"

    I do have OpenSSH in my phone, I installed it through Cydia...is there anything else I am missing or what? Can someone please help!...
    2009-05-12 07:55 PM
  8. NurkJon's Avatar
    Do you connect to the ip Since we're tunneling the data we will not use the iPhones ip. Also make sure you started iTunnel first before WinSCP. If it still doesn't work tell me what happens when you open iTunnel.
    2009-05-12 08:30 PM
  9. ifonemod's Avatar
    Do you connect to the ip Since we're tunneling the data we will not use the iPhones ip. Also make sure you started iTunnel first before WinSCP. If it still doesn't work tell me what happens when you open iTunnel.
    yeap i did it...

    here is the screen shot of what happens...
    Attached Thumbnails iUSB Tunnel-screenshot.jpg  
    2009-05-12 09:39 PM
  10. NurkJon's Avatar
    Weird, your screen shot looks just as it should look. Is it only with WinSCP or do you have the same problem with putty? Have you tried restarting your computer? I highly doubt that it could be the firewall causing it but try disable the firewall too. What iPhone model and firmware do you have? I've only tested it with iPhone 3G 2.2.1 but it should work with any iPhone running openssh. Does iTunes work good? If so try to rename your "iTunesMobileDevice.dll" (to make a backup) file and copy same file from iTunes into your iTunnel folder.

    You can find that file in "%programfiles%\Common Files\Apple\Mobile Device Support\bin\" if you're running 32bit windows and in
    You can find that file in "%programfiles(x86)%\Common Files\Apple\Mobile Device Support\bin\" if you're running 64bit. However I doubt that's the problem so try the other stuff first.
    2009-05-12 10:57 PM
  11. ifonemod's Avatar
    k so i did all of those, and none of them helped.

    I researched in google, and apparently it gives me that message because my "firewall" is blocking it, but I dont have any firewall installed on my computer, except for the Windows Firewall, which i did turn off and yet still it doesn't work...Is there a way around this?

    I really haven't installed any other firewalls nor do i see one in my control panel or the task manager services...what is wrong? :S

    k so here is a new problem...

    i got the WinSCP to work, i had to instal OpenSSL from installer since cydia didn't do that for me...but anywho now that I have the WinSCP worked, i have another problem

    it asks me for the password for "root" and i enter "alphine" it says access denied, i enter "dottie" it still says access denied...what am i doing wrong now?
    Last edited by ifonemod; 2009-05-14 at 01:04 AM. Reason: Automerged Doublepost
    2009-05-14 01:04 AM
  12. NurkJon's Avatar
    The root password is by default alpine btw not alphine. Try that.
    2009-05-14 10:00 AM
  13. ifonemod's Avatar
    thanks that worked perfectly...thanks once again
    2009-05-14 06:54 PM
  14. m.o.r.'s Avatar
    iUSB Tunnel is all over the web but not many posts here.

    nevertheless, this is fantastic work NurkJon!
    thanks for releasing such a great tool! works flawlessly.
    such a great tool to bring along on a usb flash drive.
    2009-05-15 06:21 AM
  15. NurkJon's Avatar
    Yeah I didn't think it would spread that much, i only posted about it here and at one other forum. I'm glad that you like the tool.
    2009-05-16 10:56 PM
  16. CaptainChaos's Avatar
    This works great! I have never used veency before I saw it mentioned in this program, but I am loving it! Text messaging from my laptop is a lot better than doing it from the phone Thank you for this application.
    2009-05-17 03:34 PM
  17. NurkJon's Avatar
    I'm glad that you liked it.
    2009-05-17 09:08 PM
  18. Dorkington's Avatar
    Any word on iPhone 3.0 compatibility?



    -iPhone OS 3.0
    -Open SSH 5.2p1-8 installed
    -Veency 09.2591-1 installed


    -Windows XP Professional SP3
    -Core 2 Duo 1.86ghz/2gb ram/80gb hdd
    -TightVNC 1.3.10 installed


    -On iUSB, I run "iTunnel" which launches a cmd prompt.
    -On iUSB, I launch "TightVNC" which brings up the TightVNC prompt.
    -On TightVNC, I enter, and connect with automatic options.

    The results are attached.

    Any help would be greatly appreciated.

    Thank you.
    Attached Thumbnails iUSB Tunnel-iusb-tightvnc.png  
    Last edited by Dorkington; 2009-07-01 at 05:15 PM.
    2009-07-01 05:13 PM
  19. CaptainChaos's Avatar
    I have the same issue. I was really hoping this would work when I upgraded. I don't know anything about socket errors though.

    The Lockdown folder has moved. My Lockdown is now in CProgramData\Apple\Lockdown

    I created a lockdown folder in the location it is looking for and copy/pasted the plist into it and now it connects and shows the iPhone on my screen...

    But, my iPhone freezes up causing me to hard reboot it. I can't manipulate anything on the screen of my computer.
    Last edited by CaptainChaos; 2009-07-02 at 09:41 AM. Reason: Automerged Doublepost
    2009-07-02 09:30 AM
  20. CaptainChaos's Avatar
    Ok I have it running on my screen and now it is actually showing what is going on. If I switch pages it switches pages...if I open an app it opens the app. I just can't do anything other than 1 mouse gesture and then it freezes up my phone again. This has to have something to do with Veency. I reinstalled the libraries, but it didn't help.
    2009-07-03 10:06 AM
34 12