1. Cyrusx7's Avatar
    Oh man.. long story short, I got this virus which effed up my XP so I reinstalled (I had most of my stuff backed up on another disk). Well, it was just recently that I had installed SSH and was porting over apps.. I had the root password saved in the WinSCP program as well as the original root//dottie file. Now that I reinstalled it, both are gone. I went back to http://iphone.simbunch.com/crypt.php (the site it uses to generate the encrypted root password) and retyped my unencrypted password (a common one that i use for other stuff) and got the encrypted password. I copied and pasted that into WinSCP and it keeps saying "Access denied." when I get to the password authentication..

    So, thinking desperately of what to do, I opened iBrickr and downloaded etc/master.passwd, opened it in notepad, found the encrypted key (which was the same as the one I got above), copied and pasted it into WinSCH and it didnt work.

    Lastly, I copied and pasted the wholee text from the generator site, reup'd the master.passwd file to my iPhone, tried logging in with the "surefire" password, and it STILL wouldnt work.

    WHAT DO I DO! I am desperate for help!!

    Cliffs: Lost my SSH root login password and need help restoring/resetting.
    2007-10-07 03:40 AM
  2. jedinight's Avatar
    have you tried uninstalling than reinstalling openssh it may reset back to root dottie
    2007-10-07 04:01 AM
  3. Cyrusx7's Avatar
    Ill try it, but I dont think thatll work cuz the password file is on the phone and not controlled by OpenSSH. Ill give it a shot though, thanks for the recommendation!!

    EDIT:
    It was a rly close, but didnt work. I uninstalled, reinstalled (caught the screen saying generating keys, that made me happy), tried reconnecting, same access denied :-(

    Any other ideas?

    EDIT #2:
    Can someone upload their original, unmodified master.passwd from the /ETC/ directory?
    Last edited by Cyrusx7; 2007-10-07 at 04:40 AM.
    2007-10-07 04:18 AM
  4. jedinight's Avatar
    let me know if that helps
    Last edited by jedinight; 2007-10-31 at 04:32 AM.
    2007-10-07 04:47 AM
  5. Cyrusx7's Avatar
    Alright im a bit confused, which file do I replace? "master.passwd" or just transfer that file you gave me "passwd" with no extension to the /etc/ folder? Inside I see both "master.passwd" and "passwd", not sure which is the right one? I tried using that file you gave me to replace both, but im not sure if iBrickr is really overwritting them?
    2007-10-07 04:58 AM
  6. jedinight's Avatar
    well you wanted stock master.passwd..so i zipped it for you .so extract and put in iphone..i gave you only master.passwd.. has to be extracted

    and master.passwd is what you changed to begain with right

    and winscp your going to scp protocol not sftp
    Last edited by jedinight; 2007-10-07 at 05:12 AM. Reason: Automerged Doublepost
    2007-10-07 05:12 AM
  7. Cyrusx7's Avatar
    Ok well.. I now discovered that "master.passwd" is totally different than "passwd".. After restarting my phone, I saw this crazy screen during startup:



    Damn, now I really need help.. Any ideas?
    Last edited by Cyrusx7; 2007-10-07 at 05:47 AM.
    2007-10-07 05:44 AM
  8. jedinight's Avatar
    yeah ..happened before here you got to get that sucker into restore mode...hold power down and home button till you see that yellow triangle to appear..and when you do .in itunes you need to hold shift down andclick restore ..this will let you choose the restore file..if you dont have it its here at the download section..1.0.2 ..dont update to 1.1.1..i repeat dont restore to 1.1.1..you might have to play with the holding down procees till that triangle appers...25secto 30
    2007-10-07 05:56 AM
  9. Cyrusx7's Avatar
    I would like to thank you for your help. I did as directed, selected the 1.02 firmware and hit ok. However, it didnt automatically restore, should I hit the restore button now, without shift, after I selected the file?
    2007-10-07 06:14 AM
  10. Eurisko's Avatar
    Install mobile terminal.app and run it on your iPhone. Then type: passwd root

    It should ask you to enter a new password without having to know the old one.
    2007-10-07 06:35 AM
  11. Cyrusx7's Avatar
    I got everything setup thanks to jjgsxr883.

    Thanks to everyone else for the input as well! This was a very bad experience and I hope noone has to go through it :-D
    Last edited by Cyrusx7; 2007-10-07 at 08:07 AM.
    2007-10-07 08:04 AM
  12. Coluch's Avatar
    What was the solution to this?

    I've just updated to 1.1.4 but i can't install installer.app because I can't ssh into the phone without my root password...

    I've tried changing my root password via Independence.app from my mac, but it doesn't seem work.

    Would a full on "restore" through iTunes reset it?
    iPhone 4
    iOS 4.3.3
    Carrier: Fido
    OSX Snow Leopard 10.6.8
    2008-03-01 02:22 AM
  13. zigzagler's Avatar
    Hi everyone, I just change my master.passwd and my iPhone wouldn't boot up. it shows some weird lines after the apple logo appears. I'm currently using 1.1.4 firmware unlock.
    I do however keep the original master.passwd in my laptop. I just don't know how to get the original file back into my iPhone as it wouldn't even start up. Please help me.
    Thanks in advance!
    2008-04-15 11:01 AM
  14. jtesnani's Avatar
    well, you're not supposed to change your password for ssh 1.1.3 and up. i'm not sure if there's an easy solution but as far as i know, you'll most likely have to restore. do a quick search on the forum as this has been discussed numerous times
    2008-04-15 10:19 PM
  15. StealthBravo's Avatar
    restore
    2008-04-15 10:59 PM
LINK TO POST COPIED TO CLIPBOARD