1. Dominion's Avatar
    I've done a bit of searching but I can't seem to find the answers I"m looking for. I started off by trying to find out wtf my wifi was no longer working after using ziphone. Like an idiot I just used it without researching any of the other applications used to jailbreak.

    I have a fairly new 1.1.4 otb iphone, the jailbreak and everything worked great. Everything seemed to work no problem but I kept noticing that my wifi wasn't working.

    I started to do some research and found out that zibris 'fix' was to hardcode the mac address into the wifi. I also hear tell that this app also downgrades the BL to 3.9 original. After some research I decided to do a restore, DFU mode, restore through Itunes. That works just fine, now I didn't do a big test but it SEEMED like the wireless began working just fine.

    This time I used Liberty+ to do the work, and I also set it up so that it would automatically drop in Bootneuter just incase the restore didn't work.

    After I jailbreak with Liberty+ the wifi still doesn't work, check the settings, the Zibri hardcoded mac address is still there. I still can't pull and IP address.

    I've tried restarting the iphone, resetting all settings, resetting just the access settings. Nothing has worked to pull an IP address.

    So now where I stand is I've used Bootneuter to restore my 4.6original bootloader. When I did this it failed to reflash the baseband. I am at this right now:

    Version 1.1.4 (4A102)
    Wi-Fi Address: 00:5A:49:42:52:49
    Modem Firmware 04.04.05_G


    BootNeuter reports my Bootloader as 4.6, Neuter off, Fakeblank off, Baseband unlock off.

    At this point, I'm wanting to keep 4.6 on the bootloader, keep the fakeblank off, use DFU to restore 1.1.4, see if it restores wifi access/original mac address. If it doesn't then I'll take it to the apple store and have them replace it for wifi not working and hope they don't notice the stuff I've done.

    Other than that I don't know where to proceed. I've got my original bootloader back, and am sitting on a jailbreaked iphone that works 90%, no wifi. Which normally is NOT a big deal, I tend to use the hell out of the Edge, it's just that I want a fully functioning iphone, also the second reason I want wifi is because I want to ssh into the thing to change my text message ring tone. I was happy with a legit ipod EXCEPT I can't change my text message ring tone (Seriously wtf is with that)

    Note: If I say 'ipod' in this post I really mean iphone, I haven't stopped calling it an ipod yet :P
    Last edited by Dominion; 2008-05-09 at 11:39 PM.
    2008-05-09 11:19 PM
  2. dale1v's Avatar
    Well, its good to see that you have done research, even if it was a bit late.
    Read:

    http://wikee.iphwn.org/sgold_bootrom:fixwifi
    2008-05-09 11:38 PM
  3. Dominion's Avatar
    For fun I restored my iphone to the 1.1.4 factory setting, it still has the same mac ID and it does not allow me on the wifi. So, possible I may take it back and say the wifi on it doesn't work. Dunno what I'm going to do with it honestly. If anyone knows of a fix, an actual fix I'd like to know.
    2008-05-09 11:49 PM
  4. dale1v's Avatar
    did you read the link I gave you? If you send your phone back and they see that mac address...your warranty's finished.
    2008-05-09 11:52 PM
  5. Dominion's Avatar
    Well, its good to see that you have done research, even if it was a bit late.
    Read:

    http://wikee.iphwn.org/sgold_bootrom:fixwifi
    I took a look at that but I am not sure if the problem I have is with 'wifi greyed out' or not as I can connect to the wifi, and if I recieve a call it says I HAVE wifi, but everywhere else I just get edge access. Also the IP address I do receive is a 169.x.x.x address.

    Secondary to that, how do I get these fixes onto the iphone with a windows PC, unable to use ssh or the pwnage connection thing.

    Are you able to get into the iphone via cable?

    Edit: Sorry read that a bit more closely and that looks like it will fix, but a bit over my head right now so I will keep looking at it, as soon as I can figure out how to get the files over and execute the commands, I can start working on it.
    Last edited by Dominion; 2008-05-09 at 11:56 PM.
    2008-05-09 11:54 PM
  6. dale1v's Avatar
    hmmm. I'm not sure, seeing as I've never used ZiPhone. Try using the payload function on iLiberty.
    2008-05-09 11:58 PM
  7. Dominion's Avatar
    Yes there is a 'grey wifi fix' from the dev team in iLiberty, it's one of the payloads. So I'm going to try this now, I'll let you know how works.

    Still working on fixing this, ran the wifi fix on iLiberty and it didn't seem to do anything, so going to keep seeing if there is a way to get files on there via sync cable and do the manual method.


    ::Update::
    Ok so I don't know what the hell happened but here is what I did, I was trying to figure out how to get the swifi patch onto my iphone and I first wanted to check and see what my wifi mac was reporting, so I connected to it with iBooter and it was reporting a new mac address!!! (keep in mind I hadn't done anything)

    So I reboot back into normal mode from recovery and my iphone ALSO reports this new mac address (the original address mind you)

    Now it's still not giving me an IP Address but I do have my original mac address back. So still not sure why my wifi isn't working.
    Last edited by Dominion; 2008-05-10 at 01:08 AM. Reason: Automerged Doublepost
    2008-05-10 01:05 AM
  8. dale1v's Avatar
    ah. Try reflashing your baseband now. See if that does anything.
    2008-05-10 07:45 AM
  9. Dominion's Avatar
    Reflashed to baseband 4.4.5 and still nothing. I still have a proper mac address but it refused to pull an IP from any wifi connection, secured or open.
    2008-05-11 01:29 AM
  10. crownroyal77's Avatar
    Is there a solution to this? I have the same problem. I got my original MAC back but still cannot get wifi to work.
    2008-07-17 01:51 AM
LINK TO POST COPIED TO CLIPBOARD